| 订阅 | 在线投稿
分享
 
 
 

Perl/TkFAQ-3.编译安装Perl/Tk是否需要Tcl/Tk?

2008-05-18 21:55:34 编辑來源:互联网 国际版 评论
 
 
  原文:

  3. Do I need Tcl/Tk in order to build Perl/Tk?

  Short answer: No not at all. Perl/Tk is completely independent of Tcl/Tk.

  Longer answer: In order to build Perl/Tk from source code you do need a recent version of perl, the perl/Tk source code kit, a graphical user interface library such as Xlib, Presentation Manager, or Win32; a C or C++ compiler, and a make utility. In some rare cases Perl/Tk binaries are distributed for some platforms but that is more the exception than a general rule (see below).

  If you will be attempting to port Perl/Tk to your platfrom then you might want to consult the document at: http://w4.lns.cornell.edu/~pvhp/ptk/ptkPORT.html

  where each of these components is discussed in a bit more detail (with an emphasis on Xlib).

  译文:

  3. 编译安装Perl/Tk是否需要Tcl/Tk?

  简短的回答:完全不用!因为Perl/Tk是完全不依赖Tcl/Tk的。

  更具体的回答:如果要从源代码来编译安装Perl/Tk,你需要1)较新版本的Perl;2)Perl/Tk源代码包;3)图形用户界面库,例如Xlib,显示管理器(Presentation Manager)或者Win32;4)C或C++的编译器;5)make工具。偶尔,Perl/Tk也会发布针对一些系统平台的二进制版本。

  如果你确实想在你的系统上安装Perl/Tk,那么你可以参考下面的这个文档:

  http://w4.lns.cornell.edu/~pvhp/ptk/ptkPORT.html

  这里对上面提到各个条件都做了更加详细的讨论(重点是Xlib)。
 
 
  原文:   3. Do I need Tcl/Tk in order to build Perl/Tk?   Short answer: No not at all. Perl/Tk is completely independent of Tcl/Tk.   Longer answer: In order to build Perl/Tk from source code you do need a recent version of perl, the perl/Tk source code kit, a graphical user interface library such as Xlib, Presentation Manager, or Win32; a C or C++ compiler, and a make utility. In some rare cases Perl/Tk binaries are distributed for some platforms but that is more the exception than a general rule (see below).   If you will be attempting to port Perl/Tk to your platfrom then you might want to consult the document at: http://w4.lns.cornell.edu/~pvhp/ptk/ptkPORT.html   where each of these components is discussed in a bit more detail (with an emphasis on Xlib).   译文:   3. 编译安装Perl/Tk是否需要Tcl/Tk?   简短的回答:完全不用!因为Perl/Tk是完全不依赖Tcl/Tk的。   更具体的回答:如果要从源代码来编译安装Perl/Tk,你需要1)较新版本的Perl;2)Perl/Tk源代码包;3)图形用户界面库,例如Xlib,显示管理器(Presentation Manager)或者Win32;4)C或C++的编译器;5)make工具。偶尔,Perl/Tk也会发布针对一些系统平台的二进制版本。   如果你确实想在你的系统上安装Perl/Tk,那么你可以参考下面的这个文档:   http://w4.lns.cornell.edu/~pvhp/ptk/ptkPORT.html   这里对上面提到各个条件都做了更加详细的讨论(重点是Xlib)。
󰈣󰈤
 
 
>>返回首页<<
 为你推荐
 
 
 
 转载本文
 UBB代码 HTML代码
复制到剪贴板...
 
 
 热帖排行
 
 
王朝网络微信公众号
微信扫码关注本站公众号wangchaonetcn
 
  免责声明:本文仅代表作者个人观点,与王朝网络无关。王朝网络登载此文出于传递更多信息之目的,并不意味着赞同其观点或证实其描述,其原创性以及文中陈述文字和内容未经本站证实,对本文以及其中全部或者部分内容、文字的真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
 
 
©2005- 王朝网络 版权所有