| 订阅 | 在线投稿
分享
 
 
 

CentOS编译Mysql 4.0.27数据库问题解决

来源:互联网  宽屏版  评论
2008-06-01 03:28:00

本文为【CentOS编译Mysql 4.0.27数据库问题解决】的汉字拼音对照版显示拼音

xianzaihaoduorendouyongqilecentos5danyouxieteshuyaoqiuhuanbixuanzhuangmysql4.0.27deshujukuzaidiyicianzhuangguochengzhonghuanyudaolebushaowentitebazhecianzhuangguochengjiluxialaiyigongyudaoleisiwentidepengyoushenkao

shouxianxiazaimysql4.0.27.tar.gzjieyajinrumulubianyi

bianyishichuxiancuowuchecking LinuxThreads Not found

zheshiyouyunptlyulinuxthreadsdefenbiezaochengdekeyizai/usr/include/pthread.hzhongzengjia /* Linuxthreads */jiejuezhegewenti

echo /* Linuxthreads */ >> /usr/include/pthread.h

bianyishijiaru with-pthread ji with-named-thread-lib:

chongxinbianyizaicichucuo:configure: error: No curses/termcap library found

zheshiyinweimeiyouanzhuangncursesjiexialaixiananzhuangta

yum install ncurses-devel

xialaijixubianyibianyideshihouyouchuxianlecuowu: cannot find -lreadline

zhegecuowushiyouyumeiyoureadlinekuwenjianzaochengdecuowuanzhuangreadlinekuwenjian

yum install readline-devel

./configure with-pthread with-named-thread-lib=-lpthread zaiyicijinxingbianyi

原文
现在好多人都用起了centos5,但有些特殊要求还必须安装mysql4.0.27的数据库,在第一次安装过程中还遇到了不少问题,特把这次安装过程记录下来以供遇到类似问题的朋友参考 首先下载mysql4.0.27.tar.gz,解压进入目录编译 编译时出现错误:checking “LinuxThreads”… “Not found” 这是由于nptl与linuxthreads的分别造成的,可以在/usr/include/pthread.h中增加 “/* Linuxthreads */”解决这个问题 echo ‘/* Linuxthreads */’ >> /usr/include/pthread.h 编译时加入 –with-pthread 及 –with-named-thread-lib: 重新编译再次出错:configure: error: No curses/termcap library found 这是因为没有安装ncurses,接下来先安装它 yum install ncurses-devel 下来继续编译,编译的时候又出现了错误: cannot find -lreadline 这个错误是由于没有readline库文件造成的错误,安装readline库文件 yum install readline-devel ./configure –with-pthread –with-named-thread-lib=-lpthread 再一次进行编译。
󰈣󰈤
 
 
 
>>返回首页<<
 
 热帖排行
 
 
王朝网络微信公众号
微信扫码关注本站公众号wangchaonetcn
 
 
静静地坐在废墟上,四周的荒凉一望无际,忽然觉得,凄凉也很美
©2005- 王朝网络 版权所有